CentOS7サーバでsystemctl list-unitsするとnetwork.serviceがdisabledになっている

スポンサーリンク
CentOS7
スポンサーリンク

※専用サーバで起こったケースなので、VPSやAWSなどとは状況が異なる場合があります。
systemctl list-unitsを実行したところ、network.serviceがなぜかdisabledになっています。
systemctl restart networkをしても、再起動に失敗します。
ログを見てみると、以下のようなメッセージが。

-- Unit network.service has begun starting up.
11月 09 15:54:06 ***.*** network[13157]: ループバックインターフェイスを呼び込み中 [  OK  ]
11月 09 15:54:06 ***.*** network[13157]: インターフェース enp1s0f0 を活性化中:  RTNETLINK answers: File exists
11月 09 15:54:06 ***.*** network[13157]: [  OK  ]
11月 09 15:54:06 ***.*** network[13157]: インターフェース enp1s0f1 を活性化中:
11月 09 15:54:06 ***.*** dhclient[13387]: DHCPDISCOVER on enp1s0f1 to 255.255.255.255 port 67 interval 3 (xid=0x2ffa945f)
11月 09 15:54:09 ***.*** dhclient[13387]: DHCPDISCOVER on enp1s0f1 to 255.255.255.255 port 67 interval 7 (xid=0x2ffa945f)
11月 09 15:54:16 ***.*** dhclient[13387]: DHCPDISCOVER on enp1s0f1 to 255.255.255.255 port 67 interval 14 (xid=0x2ffa945f)
11月 09 15:54:30 ***.*** dhclient[13387]: DHCPDISCOVER on enp1s0f1 to 255.255.255.255 port 67 interval 7 (xid=0x2ffa945f)
11月 09 15:54:37 ***.*** dhclient[13387]: No DHCPOFFERS received.
11月 09 15:54:37 ***.*** network[13157]: enp1s0f1 のIP情報を検出中... 失敗
11月 09 15:54:37 ***.*** network[13157]: [失敗]
11月 09 15:54:37 ***.*** network[13157]: RTNETLINK answers: File exists
11月 09 15:54:37 ***.*** network[13157]: RTNETLINK answers: File exists
11月 09 15:54:37 ***.*** network[13157]: RTNETLINK answers: File exists
11月 09 15:54:37 ***.*** network[13157]: RTNETLINK answers: File exists
11月 09 15:54:37 ***.*** network[13157]: RTNETLINK answers: File exists
11月 09 15:54:37 ***.*** network[13157]: RTNETLINK answers: File exists
11月 09 15:54:37 ***.*** network[13157]: RTNETLINK answers: File exists
11月 09 15:54:37 ***.*** network[13157]: RTNETLINK answers: File exists
11月 09 15:54:37 ***.*** network[13157]: RTNETLINK answers: File exists
11月 09 15:54:37 ***.*** polkitd[828]: Unregistered Authentication Agent for unix-process:13151:7508208043 (system bus name :1.1699641, object path /org/freedesktop/PolicyKit1/AuthenticationAgent, locale ja_JP.UTF-8
11月 09 15:54:37 ***.*** systemd[1]: network.service: control process exited, code=exited status=1
11月 09 15:54:37 ***.*** systemd[1]: Failed to start LSB: Bring up/down networking.
-- Subject: Unit network.service has failed
-- Defined-By: systemd
-- Support: http://lists.freedesktop.org/mailman/listinfo/systemd-devel
-- 
-- Unit network.service has failed.

どうやら初期設定でインターフェースが複数設定されており、その内の一つが立ち上げミスしているようです。
/etc/sysconfig/network-scripts/enp1s0f1を調べてみると、

DEVICE=enp1s0f1
BOOTPROTO=dhcp
ONBOOT=yes
DEFROUTE=no
MTU=9000

こんな感じになっていたので、ONBOOT=noにして再度再起動した所、問題は発生しませんでした。

1 Star2 Stars3 Stars4 Stars5 Stars (まだ投票されていません)
読み込み中...

コメント

広告ブロッカーを無効にしてください。

タイトルとURLをコピーしました